using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)\.html(.*)$";
string substitution = @"$1$2";
string input = @"https://example.com/about.html?pageback=video&jdjahdjahd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}