use strict;
my $str = 'webmaster@andreijiroh.eu.org
ajhalili2006@andreijiroh.uk.eu.org
admin@andreijiroh.dev';
my $regex = qr/@andreijiroh\.uk\.eu\.org$|@andreijiroh\.eu\.org$|andreijiroh\.dev/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";