import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@andreijiroh\\.uk\\.eu\\.org$|@andreijiroh\\.eu\\.org$|andreijiroh\\.dev";
final String string = "webmaster@andreijiroh.eu.org\n"
+ "ajhalili2006@andreijiroh.uk.eu.org\n"
+ "admin@andreijiroh.dev";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}