# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@andreijiroh\.uk\.eu\.org$|@andreijiroh\.eu\.org$|andreijiroh\.dev//gm;t' <<< "webmaster@andreijiroh.eu.org
ajhalili2006@andreijiroh.uk.eu.org
admin@andreijiroh.dev"