const regex = /@andreijiroh\.uk\.eu\.org$|@andreijiroh\.eu\.org$|andreijiroh\.dev/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@andreijiroh\\.uk\\.eu\\.org$|@andreijiroh\\.eu\\.org$|andreijiroh\\.dev', 'gm')
const str = `webmaster@andreijiroh.eu.org
ajhalili2006@andreijiroh.uk.eu.org
admin@andreijiroh.dev`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);