re = /(?=^[^@\/\?]*$)(\w+\.)+([A-Za-z]+){2}$/im
str = 'hello.world
hi.fr
t.co
1.1
1.co
http://www.google.com
hello@google.com
google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end