import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^[^@\\/\\?]*$)(\\w+\\.)+([A-Za-z]+){2}$";
final String string = "hello.world\n"
+ "hi.fr\n"
+ "t.co\n"
+ "1.1\n"
+ "1.co\n"
+ "http://www.google.com\n"
+ "hello@google.com\n"
+ "google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}