#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?=^[^@\/\?]*$)(\w+\.)+([A-Za-z]+){2}$"
Local $sString = "hello.world" & @CRLF & _
"hi.fr" & @CRLF & _
"t.co" & @CRLF & _
"1.1" & @CRLF & _
"1.co" & @CRLF & _
"http://www.google.com" & @CRLF & _
"hello@google.com" & @CRLF & _
"google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")