const regex = /(?=^[^@\/\?]*$)(\w+\.)+([A-Za-z]+){2}$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^[^@\\\/\\?]*$)(\\w+\\.)+([A-Za-z]+){2}$', 'igm')
const str = `hello.world
hi.fr
t.co
1.1
1.co
http://www.google.com
hello@google.com
google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}