using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^[^@\/\?]*$)(\w+\.)+([A-Za-z]+){2}$";
string input = @"hello.world
hi.fr
t.co
1.1
1.co
http://www.google.com
hello@google.com
google.com";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}