$re = '/(?=^[^@\/\?]*$)(\w+\.)+([A-Za-z]+){2}$/im';
$str = 'hello.world
hi.fr
t.co
1.1
1.co
http://www.google.com
hello@google.com
google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);