import Foundation
let pattern = ##"(?:\#|\/\/)[^\n\r]*(?<![\?>])"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
/*asdasd asdasd asdasd
asdasd asdasd asdasds?sdsd*/
/*echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>';*/
//sdsdsdsddsdsd
#sdsdsds?sdsd
<?php #echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?> ?>
<?php //echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?> ?>
<?php /*echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>';*/ ?>
<?php /*?><?php echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?><?php */?>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}