use strict;
my $str = '<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
/*asdasd asdasd asdasd
asdasd asdasd asdasds?sdsd*/
/*echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\';*/
//sdsdsdsddsdsd
#sdsdsds?sdsd
<?php #echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?> ?>
<?php //echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?> ?>
<?php /*echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\';*/ ?>
<?php /*?><?php echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?><?php */?>
';
my $regex = qr/(?:\#|\/\/)[^\n\r]*(?<![\?>])/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}