using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\#|\/\/)[^\n\r]*(?<![\?>])";
string input = @"<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
/*asdasd asdasd asdasd
asdasd asdasd asdasds?sdsd*/
/*echo'<div class=""a"" id=""a"">Content for class ""a"" id ""a"" Goes Here</div>';*/
//sdsdsdsddsdsd
#sdsdsds?sdsd
<?php #echo'<div class=""a"" id=""a"">Content for class ""a"" id ""a"" Goes Here</div>'; ?> ?>
<?php //echo'<div class=""a"" id=""a"">Content for class ""a"" id ""a"" Goes Here</div>'; ?> ?>
<?php /*echo'<div class=""a"" id=""a"">Content for class ""a"" id ""a"" Goes Here</div>';*/ ?>
<?php /*?><?php echo'<div class=""a"" id=""a"">Content for class ""a"" id ""a"" Goes Here</div>'; ?><?php */?>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}