#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\#|\/\/)[^\n\r]*(?<![\?>])"
Local $sString = "<!--- sdsdsdsdsds --->" & @CRLF & _
"" & @CRLF & _
"<!--- sdsdsdsdsds --->" & @CRLF & _
"" & @CRLF & _
"<!--- sdsdsdsdsds --->" & @CRLF & _
"" & @CRLF & _
"<!--- sdsdsdsdsds --->" & @CRLF & _
"" & @CRLF & _
"/*asdasd asdasd asdasd" & @CRLF & _
"asdasd asdasd asdasds?sdsd*/" & @CRLF & _
"" & @CRLF & _
" /*echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>';*/ " & @CRLF & _
"" & @CRLF & _
"//sdsdsdsddsdsd" & @CRLF & _
"" & @CRLF & _
"#sdsdsds?sdsd" & @CRLF & _
"" & @CRLF & _
"<?php #echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?> ?>" & @CRLF & _
"" & @CRLF & _
"<?php //echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?> ?>" & @CRLF & _
"" & @CRLF & _
"<?php /*echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>';*/ ?>" & @CRLF & _
"" & @CRLF & _
"<?php /*?><?php echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?><?php */?>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")