$re = '/(?:\#|\/\/)[^\n\r]*(?<![\?>])/';
$str = '<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
/*asdasd asdasd asdasd
asdasd asdasd asdasds?sdsd*/
/*echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\';*/
//sdsdsdsddsdsd
#sdsdsds?sdsd
<?php #echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?> ?>
<?php //echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?> ?>
<?php /*echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\';*/ ?>
<?php /*?><?php echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?><?php */?>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);