re = /(?:\#|\/\/)[^\n\r]*(?<![\?>])/
str = '<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
/*asdasd asdasd asdasd
asdasd asdasd asdasds?sdsd*/
/*echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\';*/
//sdsdsdsddsdsd
#sdsdsds?sdsd
<?php #echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?> ?>
<?php //echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?> ?>
<?php /*echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\';*/ ?>
<?php /*?><?php echo\'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>\'; ?><?php */?>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end