// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(?<title>.*)\]\((?<url>\S+)\)").unwrap();
let string = "# Hello
This is markdown sample with
[Some link](https://www.some-link.com.ua)
Have *fun*!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}