using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?<title>.*)\]\((?<url>\S+)\)";
string input = @"# Hello
This is markdown sample with
[Some link](https://www.some-link.com.ua)
Have *fun*!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}