const regex = /\[(?<title>.*)\]\((?<url>\S+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?<title>.*)\\]\\((?<url>\\S+)\\)', 'gm')
const str = `# Hello
This is markdown sample with
[Some link](https://www.some-link.com.ua)
Have *fun*!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}