package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(?<title>.*)\]\((?<url>\S+)\)`)
var str = `# Hello
This is markdown sample with
[Some link](https://www.some-link.com.ua)
Have *fun*!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}