re = /\[(?<title>.*)\]\((?<url>\S+)\)/m
str = '# Hello
This is markdown sample with
[Some link](https://www.some-link.com.ua)
Have *fun*!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end