$re = '/\[(?<title>.*)\]\((?<url>\S+)\)/m';
$str = '# Hello
This is markdown sample with
[Some link](https://www.some-link.com.ua)
Have *fun*!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);