// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"C\DO").unwrap();
let string = "Chief Compliance Officer (CCO)
Chief Security Officer (CSO)
Chief Green Officer (CGO)
Chief Analytics Officer (CAO)
Chief Marketing Officer (CMO)
Chief Data Officer (CDO)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}