$re = '/C\DO/';
$str = 'Chief Compliance Officer (CCO)
Chief Security Officer (CSO)
Chief Green Officer (CGO)
Chief Analytics Officer (CAO)
Chief Marketing Officer (CMO)
Chief Data Officer (CDO)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);