using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"C\DO";
string input = @"Chief Compliance Officer (CCO)
Chief Security Officer (CSO)
Chief Green Officer (CGO)
Chief Analytics Officer (CAO)
Chief Marketing Officer (CMO)
Chief Data Officer (CDO)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}