package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`C\DO`)
var str = `Chief Compliance Officer (CCO)
Chief Security Officer (CSO)
Chief Green Officer (CGO)
Chief Analytics Officer (CAO)
Chief Marketing Officer (CMO)
Chief Data Officer (CDO)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}