use strict;
my $str = 'Chief Compliance Officer (CCO)
Chief Security Officer (CSO)
Chief Green Officer (CGO)
Chief Analytics Officer (CAO)
Chief Marketing Officer (CMO)
Chief Data Officer (CDO)';
my $regex = qr/C\DO/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}