import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "C\\DO";
final String string = "Chief Compliance Officer (CCO)\n"
+ "Chief Security Officer (CSO)\n"
+ "Chief Green Officer (CGO)\n"
+ "Chief Analytics Officer (CAO)\n"
+ "Chief Marketing Officer (CMO)\n"
+ "Chief Data Officer (CDO)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}