// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bif\b\s*\(([\w\%\$\.]+\s*[\=\!\<\>].*[\&\|]?)?\)").unwrap();
let string = "if(%CDOCCM=\" A\")
if(CampoModif())
if(%MCRVINC=0\")
if($SCR_P_U.CHAR3!=\"P\")
if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)
if(%CBALCAO!=\"\" && %NUMCONTA!=\"\")
Limpar(%CCLIFUT)
Mandatorio(%CCLIFUT)
if(%CCLIFUT=\"\")
if(%ZCLIENTE=0)
if (%FM7 != 0)
if($TRANS_ENCADEOU_U=\"TV19\" && $cPRIMEIRAVOLTA_U=1)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}