$re = '/\bif\b\s*\(([\w\%\$\.]+\s*[\=\!\<\>].*[\&\|]?)?\)/';
$str = 'if(%CDOCCM=" A")
if(CampoModif())
if(%MCRVINC=0")
if($SCR_P_U.CHAR3!="P")
if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)
if(%CBALCAO!="" && %NUMCONTA!="")
Limpar(%CCLIFUT)
Mandatorio(%CCLIFUT)
if(%CCLIFUT="")
if(%ZCLIENTE=0)
if (%FM7 != 0)
if($TRANS_ENCADEOU_U="TV19" && $cPRIMEIRAVOLTA_U=1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);