using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bif\b\s*\(([\w\%\$\.]+\s*[\=\!\<\>].*[\&\|]?)?\)";
string input = @"if(%CDOCCM="" A"")
if(CampoModif())
if(%MCRVINC=0"")
if($SCR_P_U.CHAR3!=""P"")
if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)
if(%CBALCAO!="" && %NUMCONTA!="")
Limpar(%CCLIFUT)
Mandatorio(%CCLIFUT)
if(%CCLIFUT="")
if(%ZCLIENTE=0)
if (%FM7 != 0)
if($TRANS_ENCADEOU_U=""TV19"" && $cPRIMEIRAVOLTA_U=1)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}