use strict;
my $str = 'if(%CDOCCM=" A")
if(CampoModif())
if(%MCRVINC=0")
if($SCR_P_U.CHAR3!="P")
if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)
if(%CBALCAO!="" && %NUMCONTA!="")
Limpar(%CCLIFUT)
Mandatorio(%CCLIFUT)
if(%CCLIFUT="")
if(%ZCLIENTE=0)
if (%FM7 != 0)
if($TRANS_ENCADEOU_U="TV19" && $cPRIMEIRAVOLTA_U=1)';
my $regex = qr/\bif\b\s*\(([\w\%\$\.]+\s*[\=\!\<\>].*[\&\|]?)?\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}