package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bif\b\s*\(([\w\%\$\.]+\s*[\=\!\<\>].*[\&\|]?)?\)`)
var str = `if(%CDOCCM=" A")
if(CampoModif())
if(%MCRVINC=0")
if($SCR_P_U.CHAR3!="P")
if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)
if(%CBALCAO!="" && %NUMCONTA!="")
Limpar(%CCLIFUT)
Mandatorio(%CCLIFUT)
if(%CCLIFUT="")
if(%ZCLIENTE=0)
if (%FM7 != 0)
if($TRANS_ENCADEOU_U="TV19" && $cPRIMEIRAVOLTA_U=1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}