# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bif\b\s*\(([\w\%\$\.]+\s*[\=\!\<\>].*[\&\|]?)?\)"
test_str = ("if(%CDOCCM=\" A\")\n"
"if(CampoModif())\n"
"if(%MCRVINC=0\")\n"
"if($SCR_P_U.CHAR3!=\"P\")\n"
"if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)\n"
"if(%CBALCAO!=\"\" && %NUMCONTA!=\"\")\n"
"Limpar(%CCLIFUT)\n"
"Mandatorio(%CCLIFUT)\n"
"if(%CCLIFUT=\"\")\n"
"if(%ZCLIENTE=0)\n"
"if (%FM7 != 0)\n"
"if($TRANS_ENCADEOU_U=\"TV19\" && $cPRIMEIRAVOLTA_U=1)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.