import Foundation
let pattern = #"\[media[^\]]*?\]([\s\S]+?)\[\/media\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
string(176) "[flash]http://player.youku.com/player.php/Type/Folder/Fid/23690216/Ob/1/sid/XOTU1MjU3NjU2/v.swf[/flash][media=x,500,375]http://v.youku.com/v_show/id_XOTU0MDE3MzEy.htm[/media] "
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}