// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[media[^\]]*?\]([\s\S]+?)\[\/media\]").unwrap();
let string = "string(176) \"[flash]http://player.youku.com/player.php/Type/Folder/Fid/23690216/Ob/1/sid/XOTU1MjU3NjU2/v.swf[/flash][media=x,500,375]http://v.youku.com/v_show/id_XOTU0MDE3MzEy.htm[/media] \"
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}