const regex = /\[media[^\]]*?\]([\s\S]+?)\[\/media\]/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[media[^\\]]*?\\]([\\s\\S]+?)\\[\\\/media\\]', 'i')
const str = `string(176) "[flash]http://player.youku.com/player.php/Type/Folder/Fid/23690216/Ob/1/sid/XOTU1MjU3NjU2/v.swf[/flash][media=x,500,375]http://v.youku.com/v_show/id_XOTU0MDE3MzEy.htm[/media] "
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}