#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[media[^\]]*?\]([\s\S]+?)\[\/media\]"
Local $sString = "string(176) "[flash]http://player.youku.com/player.php/Type/Folder/Fid/23690216/Ob/1/sid/XOTU1MjU3NjU2/v.swf[/flash][media=x,500,375]http://v.youku.com/v_show/id_XOTU0MDE3MzEy.htm[/media] "" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")