re = /\[media[^\]]*?\]([\s\S]+?)\[\/media\]/i
str = 'string(176) "[flash]http://player.youku.com/player.php/Type/Folder/Fid/23690216/Ob/1/sid/XOTU1MjU3NjU2/v.swf[/flash][media=x,500,375]http://v.youku.com/v_show/id_XOTU0MDE3MzEy.htm[/media] "
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end