re = /\s*eval\(base64_decode\([^\>]*?\)\);/
str = ' eval(base64_decode("sdsadhsjdbsajdjsadksadsdsadsahsadjsabjdhbasjbdssbsdsansasadsadsadsadsa
dsadsadasddsadsdsasdsdasdssadsdhssbdjdsdsadjsaadksajdk"
));
));'
subst = '?\\>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result