import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*eval\\(base64_decode\\([^\\>]*?\\)\\);";
final String string = " eval(base64_decode(\"sdsadhsjdbsajdjsadksadsdsadsahsadjsabjdhbasjbdssbsdsansasadsadsadsadsa\n\n\n\n\n\n\n\n"
+ "dsadsadasddsadsdsasdsdasdssadsdhssbdjdsdsadjsaadksajdk\"\n\n\n\n"
+ "));\n"
+ "));";
final String subst = "?\\>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}