using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*eval\(base64_decode\([^\>]*?\)\);";
string substitution = @"?\>";
string input = @" eval(base64_decode(""sdsadhsjdbsajdjsadksadsdsadsahsadjsabjdhbasjbdssbsdsansasadsadsadsadsa
dsadsadasddsadsdsasdsdasdssadsdhssbdjdsdsadjsaadksajdk""
));
));";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}