const regex = /\s*eval\(base64_decode\([^\>]*?\)\);/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*eval\\(base64_decode\\([^\\>]*?\\)\\);', '')
const str = ` eval(base64_decode("sdsadhsjdbsajdjsadksadsdsadsahsadjsabjdhbasjbdssbsdsansasadsadsadsadsa
dsadsadasddsadsdsasdsdasdssadsdhssbdjdsdsadjsaadksajdk"
));
));`;
const subst = `?\>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);