$re = '/\s*eval\(base64_decode\([^\>]*?\)\);/';
$str = ' eval(base64_decode("sdsadhsjdbsajdjsadksadsdsadsahsadjsabjdhbasjbdssbsdsansasadsadsadsadsa
dsadsadasddsadsdsasdsdasdssadsdhssbdjdsdsadjsaadksajdk"
));
));';
$subst = "?\>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;