use strict;
my $str = ' eval(base64_decode("sdsadhsjdbsajdjsadksadsdsadsahsadjsabjdhbasjbdssbsdsansasadsadsadsadsa
dsadsadasddsadsdsasdsdasdssadsdhssbdjdsdsadjsaadksajdk"
));
));';
my $regex = qr/\s*eval\(base64_decode\([^\>]*?\)\);/p;
my $subst = '?\\>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";