# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+? (?<name>.+?) \((?<points>\d+) points?\)\n\n(?<description>.*?)\nEdit\nClone\nRemove\n"
test_str = ("2. Unit test (2 points)\n\n"
"Test checkCharacter(\"word\", 3).equals(\"Character 'd' is a letter\")\n\n"
"Edit\n"
"Clone\n"
"Remove\n")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.