import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+? (?<name>.+?) \\((?<points>\\d+) points?\\)\\n\\n(?<description>.*?)\\nEdit\\nClone\\nRemove\\n";
final String string = "2. Unit test (2 points)\n\n"
+ "Test checkCharacter(\"word\", 3).equals(\"Character 'd' is a letter\")\n\n"
+ "Edit\n"
+ "Clone\n"
+ "Remove\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}