using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+? (?<name>.+?) \((?<points>\d+) points?\)\n\n(?<description>.*?)\nEdit\nClone\nRemove\n";
string input = @"2. Unit test (2 points)
Test checkCharacter(""word"", 3).equals(""Character 'd' is a letter"")
Edit
Clone
Remove
";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}