const regex = /.+? (?<name>.+?) \((?<points>\d+) points?\)\n\n(?<description>.*?)\nEdit\nClone\nRemove\n/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+? (?<name>.+?) \\((?<points>\\d+) points?\\)\\n\\n(?<description>.*?)\\nEdit\\nClone\\nRemove\\n', 's')
const str = `2. Unit test (2 points)
Test checkCharacter("word", 3).equals("Character 'd' is a letter")
Edit
Clone
Remove
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}